comprendre pourquoi after effect rame

comprendre pourquoi after effect rame - Matériels & problèmes divers - Hardware

Marsh Posté le 22-03-2017 à 09:50:33    

Salut à tous,
voilà je bosse sous after et ça lag de ouf dès que mon projet devient un peu conséquent.
Or, quand je fais un HWmonitor ou moniteur de performance rien ne semble être collé au plafond.
 
Ma config :
CM : Asus Sabertooth 990fx
CPU : AMD FX8350
GPU : Quadro K2000
RAM : 12Go DDR3 @1300
Disques : 1 SSD pour l'OS, 1 HDD 1To @7200 rpm pour les rushs
(je vais tout de même choper un nouveau DD pour en faire mon disque de travail, le SSD est quasi full)
Soft : Ae CC, qui tourne donc sous Win10
 
Je n'arrive pas à identifier le point faible de la config et ce que je pourrais faire pour améliorer la situation.
 
Merci de vos avis avisés :jap:


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 09:50:33   

Reply

Marsh Posté le 22-03-2017 à 09:52:32    

tu a pensé simplement a regarder le gestionnaire de taches pour savoir ce qui est limitant ?
CPU, RAM, utilisation CPU, ...


---------------
On a deux vies, et la deuxième commence quand on se rend compte qu’on n’en a qu’une. ( Confucius )
Reply

Marsh Posté le 22-03-2017 à 09:56:45    

C'est bien ce que je dis, aucun composant ne semble être à son maximum quand je contrôle leur activité.
Le plus surprenant est le GPU qui semble être en RTT alors que j'utilise beaucoup d'effets et d'outils assez gourmand.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 10:08:11    

Pour être plus précis ma RAM ne semble jamais dépasser les 66% d'utilisation, mon CPU tourne entre 50 et 60%, avec quelques pics parfois,
mes disques sont entre 0 et 1% de temps d'utilisation max, et mon GPU sirote des mojitos entre 2 et 5%.
Malgré toutes ces données, je peux avoir des temps d'affichages et de chargements des previews très longs (genre 30sec ou plus pour afficher une frame sur un calque de roto-pinceau)


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 10:33:03    

Bonjour,
 
quel version d'after effect utilises-tu?
AE est installé sur ton ssd?
tu réalises quel type de projet conséquent?
as tu media encoder?
 
il faudrait consulter les options du menu préférences  tel :
 
-la "prévisualisation"  => carte nvidia activé et/ou prise en charge? un facteur important dans ton cas
- la  mémoire => ram mise à dispo?  
- et le cache disque => activé ? go utilisé? et chemin d'accès?
 
il y a d'autre options à zoomer notamment dans les paramètres de projet et au niveau de ton plan de travail aussi.
 
 
 

Reply

Marsh Posté le 22-03-2017 à 10:36:25    

rappa a écrit :

le SSD est quasi full)


 
c'est peut être une partie du problème : il ne faut jamais remplir un SSD, il faut laisser environ 20% d'espace libre sinon les débits en écriture s'effondrent.
sinon after effects est bien installé sur SSD?
tes documents de travail sont sur SSD?
 
Après la notion de "ramer" avec un programme comme after effects, c'est subjectif.. Faudrait voir sur quoi tu travailles exactement et quel est le résultat.  
parce que là, on nage, il n'y a rien de vraiment concret.

Reply

Marsh Posté le 22-03-2017 à 10:58:45    

Merci pour vos pistes.
J'utilise Ae CC 2015, et celui-ci est bien installé sur le SSD.  
Mes rush sont sur le HDD ainsi que le projet Ae (c'est peut être pas malin ça, je vais tenter sur le ssd).
 
Pour préciser mon projet actuel :
détourage de personnage sur un petit montage issu de PP CC (1'12 ; 24 clips), utilisation du roto-pinceau, amélioration du contour (décalage, progressivité, flou de mouvement).


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 11:00:14    

ip-man a écrit :


il faudrait consulter les options du menu préférences  tel :
 
-la "prévisualisation"  => carte nvidia activé et/ou prise en charge? un facteur important dans ton cas
- la  mémoire => ram mise à dispo?  
- et le cache disque => activé ? go utilisé? et chemin d'accès?
 
il y a d'autre options à zoomer notamment dans les paramètres de projet et au niveau de ton plan de travail aussi.


Merci :jap:
j'ai un rendu en cours, dès que c'est fini je contrôle tout ça.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 11:22:12    

Dans mes préférences de prévisualisations j'ai ça :

Citation :

Ebauche rapide : Disponible
 Mémoire de textures : 806,00 Mo
Lancer de rayon : GPU
 
OpenGL
Fournisseur : NVIDIA Corporation
Périphérique : Quadro K2000/PCIe/SSE2
Version : 2.1.2 NVIDIA 369.09
Mémoire totale : 1,97 Go
Modèle d’ombrage : 4.0 ou plus récent  
CUDA
Version du pilote : 8.0
Périphériques : 1 (Quadro K2000)
Mémoire utilisable actuelle : 1,66 Go (au lancement de l’application)
Mémoire utilisable max. : 2,00 Go


Pour la RAM j'ai 10Go de mis à dispos.
Le cache disque est bien activé et sur mon ssd.
Il ne fait que 11Go car je n'ai pas plus d'espace dispos sur mon ssd, je dois choper un hdd aujourd'hui qui ne servira qu'à ça. Peut être que ça améliorera les choses.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 11:24:07    

rappa a écrit :

Merci pour vos pistes.
J'utilise Ae CC 2015, et celui-ci est bien installé sur le SSD.  
Mes rush sont sur le HDD ainsi que le projet Ae (c'est peut être pas malin ça, je vais tenter sur le ssd).


 
tu devrais voir une bonne différence

Reply

Marsh Posté le 22-03-2017 à 11:24:07   

Reply

Marsh Posté le 22-03-2017 à 20:17:29    

J'ai donc rapatrier mon projet Ae sur mon SSD sytème et installé un hdd exclusivement réservé au cache, et la situation semble s'être améliorée quelque peu.  
Cependant mon GPU continu à se tourner les pouces, que ce soit pour les rendus, les previews, ou la propagation d'effets. C'est relativement frustrant.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 22-03-2017 à 23:34:42    

ok pour le paramétrage de ta carte graphique pro=>  pourquoi avoir opter pour celle ci?
 
j'ai un gpu gamer nvidia  et niveau monitoring c'est pareil pour moi, mais ca bosse  et rapidement vu le nombre de cuda que ma carte embarque.
test sans le gpu d'activer ( mode unité central ,cpu si tu préfères) et tu verra que ton cpu va vite grimper en flèche.
 
sous la fenêtre de composition tu as quelques menu dont 2 intéressant pour rendre ton travail plus réactif.
- résolution qui se trouve à coté du menu couleur rgb (rouge vert bleu), tu peux diminuer la résolution de ya compo ( auto , integrale, 1/2 etc  ).
- previsu rapide via un logo en forme d'éclair facon logiciel winamp, je te conseil de paramétrer en résolution adaptative  
 
tant qu à faire de la  place sur ton ssd , réalise un nettoyage des fichiers de mise à jour de windows 10 via les propriété du disque (clique droit sur c) et
 tu sélectionnera à un moment donner nettoyage fichiers système.
un menu appaitra et tu sélectionnera tout se qui se rapproche au maj de windows  avec la capacité occupée
 
 
 
 
 

Reply

Marsh Posté le 23-03-2017 à 09:52:49    

Merci pour tes recommandations ip-man :jap:
J'avais vu pour la résolution, je vais pouvoir effectivement la baisser suivant ce sur quoi je travaille.
Pour le choix du gpu, c'est un achat d'occasion que j'ai fait l'année dernière. Je me rends compte que c'était pas forcément le meilleur rapport qualité/prix avec seulement 400 cuda cores.
Mais ce que je comprends pas c'est qu'elle ne semble pas travailler, même quand je la désactive, je ne note pas de différence de charge sur le cpu :/


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 23-03-2017 à 11:07:42    

Une mise à jour du driver de la carte graphique ? A vérifier éventuellement

Reply

Marsh Posté le 23-03-2017 à 11:18:29    

sebg@33 a écrit :

Une mise à jour du driver de la carte graphique ? A vérifier éventuellement


J'ai tenté, ça n'a rien donné.
Peut être tout simplement que ma CG est obsolète  :??:  


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 23-03-2017 à 13:37:29    

gpu desactivé, c'est surtout en rendu qu il faut zoomer la charge cpu.
par contre il faut vider les caches pour établir un recalcul de ta compo ;) et tu verra que sur ta time line, cela sera plus long aussi (barre verte en haut)
 
tu as la version cc 2015.3?  car celle ci apportait d'importantes améliorations
onglet aide> a propos de.

Reply

Marsh Posté le 23-03-2017 à 18:49:43    

Non, j'utilise la version 2015.2.
Par contre quand je cherche les mises à jour auto, il ne m'est pas proposé de passer à la .3. Faut le faire "'manuellement" ?
Par précaution par contre, je ne le ferais pas avant d'avoir rendu ce projet.
Je suis ultra à la bourre et je peux pas me permettre un bug lié à une maj :p
De toute façon j'ai effectué un pré-rendu de mon détourage au roto-pinceau, je peux donc à nouveau bosser dans des conditions acceptables.


Message édité par rappa le 23-03-2017 à 18:52:47

---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 24-03-2017 à 15:48:46    

il rame parce qu’il n'a pas de moteur .... after effect ramera de toute facon dès qu'un projet deviendra important . J'ai déja eu à dispo des bancs de montage à base de xeon avec 32 go de ram des cartes dédiées bien plus puissantes que la tienne et ... ce n’était pas folichont ... y'a pas grand chose a faire ... tu taf sur quel format ?

Reply

Marsh Posté le 24-03-2017 à 18:53:28    

Ouais en fait je pense que ramer c'est tout relatif comme le disait un précédent intervenant...
Je bosse sur des rush FHD en H.264 (issus de reflex Canon). Je pense que c'est pas le top comme format à monter/traiter, peut être faudrait-il que je revoie mon workflow.
Le truc qui m'étonne toujours par contre, c'est le gpu toujours au repos... Tout à l'heure j'ai fait un rendu, gpu-z me donnait jamais plus de 5% de gpu load...


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 24-03-2017 à 20:38:45    

c'est plus ou moins normal , mais le h264 est light ya pire ... ;)

Reply

Marsh Posté le 24-03-2017 à 21:54:23    

Oui le h264 est light, mais j'ai entendu dire que c'était pas forcément ce que nos logiciels préférés digéraient le mieux.  
Une de mes connaissances me disait tout passer en ProRes avant de passer sur le banc de montage. Faudrait que je creuse plus avant le sujet parce que la personne qui m'a dit ça a de bonnes connaissances.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le 27-03-2017 à 16:27:18    

Pro res bouffe pas mal . et si ta sortie de matos est en 264 pas d’intérêt a aller sur autre chose. tu as d'autres options ?

Reply

Marsh Posté le 30-03-2017 à 14:02:11    

J'ai voulu tester cette fonction de roto et la mémoire est vraiment très utilisé sur un fichier h264 ou prores (8go environs à lui seul ... );
dommage que  l'option de rendu multicoeurs n'est plus présente depuis cc 2015  car ça aurait été intéressant de tester.
De plus AE  recommande d'acter l'outil roto en mode intégrale au niveau du calque pour éviter les effets de pixélisation afin d'être très précis , donc forcement que ça rame.
Par contre il y a la fonction dite "gelé" sur la droite du calque  qui permet à AE de calculer une seul fois  la roto réalisée sur ton calque ce qui permet  d'avoir une bien meilleur fluidité sur la compo. (ca évite un recalcul à chaque prévisu, modif;  ouverture de fichier...).
J'ai remarqué que  le fichier cache se rempli bien vite et te recommande de l'augmenter et de vérifier sa taille et/ou éventuellement le vider.
 
pour encoder sous prores, tu vas perdre du temps après cela dépend combien dure tes métrages?
auquel cas je te recommande Tencoder qui permet cette action et bien sur il te faut quicktime d'installer et le codec miraizon prores.... plus disponible par la maison mère miraizon car acquise par un repreneur au bras long... ( tu as le codec dnxhd aussi et gratuit)
La fluidité reste en hausse sous AE mais je n'ai pas tester dans ces derniers retranchements par contre  sous Pr c'est royale notamment pour les prévisu en prores te donnant une bonne fluidité et des rendu final rapide et au top.
Tu peux laisser le codec de sortie finale en prores mais le fichier est lourd donc mieux vaut conserver h264 qui reste déjà de très bonne qualité avec un fichier beaucoup moins lourd à transmettre.
 
 
ce qui est dommage sous AE, c'est qu il ne permet pas de paramétrer les rendu de prévisu réaliser au fil de l'eau  contrairement à PR.
et heureusement que le dynamic link permet une interaction efficace entre les logiciels d' adobe, ce qui permet d' acter un effet sous AE dans une partie  de la  séquence vidéo de première. le gain de temps est juste au top (pas de rendu, de rerendu car erreur etc....)
 
 
ps: juste pour finaliser l' optimisation d'AE, active en cochant l'accélération matérielle (carte graphique) pour les calques, composition dans préférence > affichage


Message édité par ip-man le 30-03-2017 à 14:10:13
Reply

Marsh Posté le 30-03-2017 à 22:56:32    

Merci pour ces nouveaux conseils.
J'ai bien coché l'option d'accélération matérielle dans 'affichage'.
En fait, je crois que le roto-pinceau est très gourmand et qu'effectivement il faut geler dès que possible.


---------------
https://poulout.tumblr.com/
Reply

Marsh Posté le    

Reply

Sujets relatifs:

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed